Outage and maintenance events typically affect only a small portion of the subscribers in a service area and do not necessarily indicate a city‑wide or network‑wide impact
If you are still experiencing problems once services have been restored, please try power cycling your UTOPIA Fiber equipment. For a how-to guide on how to do this visit our troubleshooting page.
Scheduled Maintenance - Midvale (TID#25789)
Completed
Scheduled for May 07, 2026 at 4:00 AM – 10:05 AM
Affects
UTOPIA Fiber Network
Under maintenance from 4:00 AM to 10:05 AM
Midvale
Under maintenance from 4:00 AM to 10:05 AM
Updates
Completed
May 07, 2026 at 10:05 AM
Completed
May 07, 2026 at 10:05 AM
UTOPIA Fiber has successfully completed the maintenance in Midvale. Services for affected customers have been restored.
In progress
May 07, 2026 at 4:00 AM
In progress
May 07, 2026 at 4:00 AM
Maintenance is now in progress
Planned
May 07, 2026 at 4:00 AM
Planned
May 07, 2026 at 4:00 AM
Maintenance scheduled for UTOPIA Fiber equipment in Midvale. Affected customers may temporarily lose service during the maintenance window. Follow for updates.