Please note: Listed outage and maintenance events typically affect only a small portion of the subscribers in a service area and do not necessarily indicate a city‑wide or network‑wide impact
#23253 Outage
Resolved
Partial outage
Started 4 months agoLasted about 9 hours
Affected
UTOPIA Fiber Network
Partial outage from 8:33 PM to 5:19 AM
Murray
Partial outage from 8:33 PM to 5:19 AM
Updates
Update
Update
UTOPIA has resolved the outage. Services for affected customers have been restored.
Resolved
Resolved
UTOPIA has resolved the outage. Services for affected customers have been restored.
Investigating
Investigating
UTOPIA is investigating an outage in Murray (MU018). Affected customers may be without service.