UTOPIA Fiber Network - #23197 Outage – Incident details

Please note: Listed outage and maintenance events typically affect only a small portion of the subscribers in a service area and do not necessarily indicate a city‑wide or network‑wide impact

#23197 Outage

Resolved
Major outage
Started 4 months agoLasted about 2 hours

Affected

UTOPIA Fiber Network

Major outage from 2:21 AM to 4:18 AM

Brigham City

Major outage from 2:21 AM to 4:18 AM

Updates
  • Resolved
    Resolved

    UTOPIA has resolved the outage. Services for affected customers have been restored.

  • Investigating
    Investigating
    UTOPIA is investigating an outage in Brigham City (BR001). Affected customers may be without service.